とあるエンジニアの闇歴史帳

コピペで使える便利Wiki ※現在構築中です。

ユーザ用ツール


senchatouch:error5

差分

このページの2つのバージョン間の差分を表示します。

この比較画面にリンクする

senchatouch:error5 [2017/12/14 20:18]
senchatouch:error5 [2020/06/23 14:10] (現在)
行 1: 行 1:
 +====== ビルド時に「no such file to load -- rubygems (LoadError)」と出て止まる ======
 +~~socialite~~
 +
 +ビルド中に次のエラーが出た場合はRubyのバージョンを疑ってみてください。
 +
 +<code>
 +[INF] executing compass using system installed ruby runtime
 +/usr/local/Sencha/Cmd/4.0.2.67/extensions/sencha-compass/gems/bin/compass:9:in `require': no such file to load -- rubygems (LoadError)
 + from /usr/local/Sencha/Cmd/4.0.2.67/extensions/sencha-compass/gems/bin/compass:9
 +[ERR] 
 +[ERR] BUILD FAILED
 +[ERR] com.sencha.exceptions.ExProcess: compass process exited with non-zero code : 1
 +</code>
 +
 +私の環境では
 +  * Ruby1.8.7
 +  * Sencha Cmd v4.0.2.67
 +で上記の現象が発生しましたが、Ruby2.0.0に入れ直したところ正常に動作するようになりました。
 +
 +===== 関連書籍 =====
 +{{amazon>jp:B00L10N8T8}}
 +<html><p style="clear:both"></p></html>
 +
 +{{amazon>jp:B00MB6GOU6}}
 +<html><p style="clear:both"></p></html>
 +
 +{{amazon>jp:B00HEB6UFM}}
 +<html><p style="clear:both"></p></html>
 +
 +{{amazon>jp:B00G9QISLC}}
 +<html><p style="clear:both"></p></html>
 +
 +{{tag>SenchaTouch エラー}}
 +~~socialite~~
  

関連ページ